Question I would like to force Facebook to rip an image I have created and not the logo

  • Mark Simon
  • Mark Simon's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
1 week 2 days ago #1665 by Mark Simon
Hi 
I am using SP-Pagebuilder to build my specific page which is then openned through a menu and when I do a facebook image rip it insists on pulling the logo image instead of any article images.
I have just subscribed for ochOpenGraph plugin and have to admit I am extremely confused how to proceed with the settings?
I am not sure if this becomes a public post so if you need me to send you login settings for the website so that you can take a look, please contact me directly.

Please Log in or Create an account to join the conversation.

More
1 week 2 days ago #1666 by Ruud van Lent
Hi Mark, ochOpenGraph is a content plugin that get 'triggered' when Joomla displays the content. Possibly the page builder has its own logic of displaying the content. As there are many page builders out there it is difficult to give directions.
Currently I'm offline (vacation) this evening I'm back at my computer and can have a look. If you can email me the credentials and some instructions / urls of the page it concerns etc. I can have s look. You can email me via the contact form or info at online community hub dot nl

Please Log in or Create an account to join the conversation.

  • Mark Simon
  • Mark Simon's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
1 week 2 days ago #1667 by Mark Simon

Please Log in or Create an account to join the conversation.

More
1 week 1 day ago #1668 by Ruud van Lent
Hi Mark,
so I had a quick look:
you have set up the page as follows:
  1. you have created a SP pagebuilder page that displays a module
  2. the module you display is a rs-forms module
ochOpenGraph is a content plugin and works only when triggered. This should be done by the module / component. As it turns out both SP page bulder and rs-forms do not folow this Joomla functionality to add / alter the content displayed :(

I saw that per page in SP pagebuilder you can specify a specific open graph image. So for this page you could use that.

another 'work-around' is create an additional custom html module where you set the ochOpenGraph tag as content. This module you can set to process content: tthe tag (with parameters will then be processed). You can then add this custom module to the drivers / any page that doesn't support content plugins.
instructions on how to do that can be found here: onlinecommunityhub.nl/documentation/ocho...ugin#manual-settings

 

Please Log in or Create an account to join the conversation.

Log In or Sign Up

Forgot your password? / Forgot your username?